Can't find Qt prerequisite package

Installing SecAst, prerequisites, basic configuration, and troubleshooting performance and technical issues. As well, upgrades to SecAst and any underlying software.
Post Reply
User avatar
CRM User
Posts: 175
Joined: Sun Nov 27, 2016 3:41 pm

Can't find Qt prerequisite package

Post by CRM User » Fri Dec 02, 2016 4:32 pm

The Linux distro I'm using only offers Qt version 5.3 as a package, but I see your software needs Qt version 5.5 or later. How do I install that prerequisite? I've searched every repo and no one has the Qt framework prebuilt for my Linux Distro.
Account for questions transferred from CRM system
User avatar
Telium Support
Posts: 235
Joined: Sun Nov 27, 2016 3:27 pm

Re: Can't find Qt prerequisite package

Post by Telium Support » Fri Dec 02, 2016 4:36 pm

Most Linux distributions are starting to include Qt version 5.7 (as of December 2016) so check available repos (including testing repos) first to ensure it's not there. If you can find Qt version 5.5 or later as a package it's best to install from your package manager. Otherwise continue on below.

If you are running Ubuntu you can check this link for a step-by-step guide to installing Qt 5.x: ... ntu-16-04/

If your system runs headless (i.e. no graphical shell) then you can also modify the Qt installer to run without its GUI as described here: ... ntu-server

If the above suggestions don't work, then we recommend you download 'Qt Creator' directly from This package is overkill, but it does an excellent job of installing everything you need (and more) relating to Qt.

After that you should have Qt 5.7 or later installed, including other Qt dependencies listed in the installation guide.
Post Reply